DHCP – Mise en place d’un DHCP-relais

Fonctionnement de l’Agent-Relais

L’Agent-Relais est un serveur qui permet de diffuser des plages d’adresses qui ne sont pas sur le même réseau que celui du serveur DHCP.

Il permet d’assurer le routage entre les réseaux, pour cela il dispose de deux cartes réseau configurés avec des adresses IP statiques. L’une de ses cartes sera sur le même réseau que le serveur DHCP contrairement à l’autre qui ne sera pas sur le même réseau.

Le serveur DHCP aura donc en passerelle l’adresse IP de l’Agent-Relais.

La commande ip helper-address   permet de  déclarer au routeur  l’adresse ip du serveur dhcp

Aller sur le routeur et modifier comme ci-dessous

#vlan wifi
interface FastEthernet0/0.50
encapsulation dot1Q 50
ip helper-address 172.16.2.5
ip address 172.19.0.129 255.255.255.128

#vlan users
interface FastEthernet0/0.60
encapsulation dot1Q 60
ip helper-address 172.16.2.5
ip address 172.19.0.1 255.255.255.128


L’adresse 172.16.2.5 correspond au serveur DHCP

Tests :

Pour le test, lancer une machine virtuelle dans le vlan 10. Configurer le réseau en mode DHCP.

vérifier l’ip qu’elle a recu, ca doit correspondre à la plage configurée plutôt.

Leave a Reply